GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages


Manual Reference Pages  -  CEYLON-VERSION (1)

NAME

ceylon version - Shows and updates version numbers in module descriptors

CONTENTS

Synopsis
Description
Options
Examples

SYNOPSIS

ceylon version \kx [--confirm=option] [--cwd=dir] [--dependencies] [--encoding=charset] [--no-update-dependencies] [--set=value] [--source=dirs...] [--src=dir...] [--verbose[=flags]] [--] [modules]...

DESCRIPTION

If --set is present then update the module versions, otherwise show the module versions.

If --dependencies is present then show the versions of module imports of the given module(s).

<modules> specifies the module names (excluding versions) of the modules to show or whose versions should be updated. If unspecified then all modules are shown/updated.

Note: Other modules may also be updated unless the --no-update-dependencies option is used, even if they’re not listed in <modules>

OPTIONS

--confirm=option
  Used with --set, determines which updates require confirmation.
o --confirm=all requires confirmation on the console for each update performed.
o --confirm=dependencies means that confirmation is only required when updating versions appearing in module imports; module versions are updated without confirmation.
o --confirm=none prevents any confirmation.

(default: all).

--cwd=dir
  Specifies the current working directory for this tool. (default: the directory where the tool is run from)
--dependencies
  Display modules who depend on the given module. Only used when displaying modules, not when setting a new version.
--encoding=charset
  Used with --set, sets the encoding used for reading and writing the module.ceylon files (default: platform-specific).
--no-update-dependencies
  Do not update of the version in module imports of the target module(s) in other modules in the given --src directories. For example:

ceylon version --set 1.1 ceylon.collection

would update the version of ceylon.collection to 1.1 and update the module import version of all dependent modules in the given --src directories which depended on ceylon.collection __even if those modules are not listed as <modules>__.

Whereas:

ceylon version --set 1.1 --no-update-dependencies ceylon.collection

would just update the version of ceylon.collection to 1.1, leaving dependent modules depending on the old version.

--set=value
  The new version number to set.If unspecified then module versions are shown and not updated.
--source=dirs
  An alias for --src (default: ./source)
--src=dir
  A directory containing Ceylon and/or Java source code (default: ./source)
--verbose[=flags], -d
  Produce verbose output. If no flags are given then be verbose about everything, otherwise just be verbose about the flags which are present. Allowed flags include: all, loader.

EXAMPLES

Listing the versions of all the modules in the ceylon SDK:

ceylon version

Listing the version of ceylon.collection, and modules that depend on it

ceylon version --dependencies ceylon.collection

Updating the version of ceylon.collection, and the modules that depend on it

ceylon version --set 1.0.1 ceylon.collection

Search for    or go to Top of page |  Section 1 |  Main Index


CEYLON VERSION (1) 10 February 2016

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with manServer 1.07.