GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
NG_EIFACE(4) FreeBSD Kernel Interfaces Manual NG_EIFACE(4)

ng_eiface
generic Ethernet interface netgraph node type

#include <netgraph/ng_eiface.h>

The eiface netgraph node implements the generic Ethernet interface. When an eiface node is created, a new interface appears which is accessible via ifconfig(8). These interfaces are named “ngeth0”, “ngeth1”, etc. When a node is shut down, the corresponding interface is removed, and the interface name becomes available for reuse by future eiface nodes. New nodes always take the first unused interface.

An eiface node has a single hook named ether, which should be connected to the Ethernet downstream, for example, to the ng_vlan(4) node. Packets transmitted via the interface flow out this hook. Similarly, packets received on the hook go to the protocol stack as packets received by any real Ethernet interface.

This node type supports the generic control messages, plus the following:
(set)
Set link-level address of the interface. Requires struct ether_addr as an argument. This message also has an ASCII version, called “set”, which requires as an argument an ASCII string consisting of 6 colon-separated hex digits.
(getifname)
Return the name of the associated interface as a NULL-terminated ASCII string.
Return the list of link-level addresses associated with the node.

This node shuts down upon receipt of a NGM_SHUTDOWN control message. The associated interface is removed and its name becomes available for reuse by future eiface nodes.

Unlike most other node types, an eiface node does not go away when all hooks have been disconnected; rather, an explicit NGM_SHUTDOWN control message is required.

netgraph(4), ng_ether(4), ng_iface(4), ng_vlan(4), ifconfig(8), ngctl(8)

The eiface node type was implemented in FreeBSD 4.6.

The eiface node type was written by Vitaly V Belekhov. This manual page was written by Gleb Smirnoff.
May 14, 2019 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.