GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PWC(4) FreeBSD Kernel Interfaces Manual PWC(4)

pwc
USB webcam driver

/dev/video0

The pwc driver provides support for various USB webcams. The driver is based on the Linux pwc webcam driver and uses the same API.

The following device hints may be added to /boot/device.hints to further configure the driver:

hint.pwc.0.power_save
When power_save is enabled (set to 1), the module will try to shut down the cam on close() and re-activate on open(). This will save power and turn off the LED. Not all cameras support this though (the 645 and 646 don't have power saving at all), and some models don't work either (they will shut down, but never wake up). Consider this experimental. By default this option is disabled.
hint.pwc.0.stats
When enabled (set to 1) frame statistics are written to the console each time the device is closed.
hint.pwc.0.led_on
This setting defines the on time for the LED (in milliseconds). One of the interesting things that you can do with this is together with the hint.pwc.0.led_off hint is to let the LED blink while the camera is in use. This:

hint.pwc.0.led_on="500"
hint.pwc.0.led_off="500"

will blink the LED once every second. But with:

hint.pwc.0.led_on="0"
hint.pwc.0.led_off="0"

the LED never goes on, making it suitable for silent surveillance.

By default the camera's LED is on solid while in use, and turned off when the camera is not used anymore.

This parameter works only with the ToUCam range of cameras (720, 730, 740, 750) and OEMs. For other cameras this command is silently ignored, and the LED cannot be controlled.

hint.pwc.0.led_off
This setting defines the off time for the LED (in milliseconds)
hint.pwc.0.compression
Sets the initial compression preference for all cameras. With this option you can control the compression factor that the camera uses to squeeze the image through the USB bus. You can set the parameter between 0 and 3:
0
prefer uncompressed images; if the requested mode is not available in an uncompressed format, the driver will silently switch to low compression.
1
low compression.
2
medium compression.
3
high compression.

High compression takes less bandwidth of course, but it could also introduce some unwanted artefacts. The default is 2, medium compression.

The compression parameter does not apply to the 645 and 646 cameras and OEM models derived from those (only a few). Most cams honour this parameter.

hint.pwc.0.fps
Sets the default framerate when you open() the device; this is to accommodate some tools that don't set the framerate. Is an integer in the range of 5-30.
hint.pwc.0.size
Sets the default size when you open() the device; this is to accommodate some tools that don't set the size. Can be one of 'sqcif', 'qsif', 'qcif', 'sif', 'cif' or 'vga', for an image size of resp. 128x96, 160x120, 176x144, 320x240, 352x288 and 640x480 (of course, only for those cameras that support these resolutions).
hint.pwc.0.pad
Normally when an application requests an image size that is not supported by the webcam, the driver will try to set the webcam to a smaller supported image size and pad the resulting image with borders. If you set this parameter to 0 this behaviour is disabled and the driver will fail image size requests that are not supported by the webcam.
hint.pwc.0.fbufs
This parameter specifies the number of internal buffers to use for storing frames from the cam. This will help if the process that reads images from the cam is a bit slow or momentarily busy. However, on slow machines it only introduces lag, so choose carefully. The default is 3, which is reasonable. You can set it between 2 and 5

The pwc driver supports the following USB webcams:

  • Philips PCA645VC
  • Philips PCA646VC
  • Philips PCVC675K (Vesta)
  • Philips PCVC680K (Vesta Pro)
  • Philips PCVC690K (Vesta Pro Scan)
  • Philips PCVC730K (ToUCam Fun)
  • Philips PCVC740K (ToUCam Pro)
  • Philips PCVC830K (ToUCam Fun II)
  • Philips PCVC840K (ToUCam Pro II)
  • Philips PCVC750K (ToUCam Pro Scan)
  • Philips PCVC720K/40 (ToUCam XS)
  • Philips SPC900NC (ToUCam Pro III)
  • Logitech QuickCam Pro 3000
  • Logitech QuickCam Notebook Pro (Old version)
  • Logitech QuickCam Pro 4000
  • Logitech QuickCam Zoom
  • Logitech QuickCam Zoom (new model)
  • Logitech QuickCam Orbit/Sphere (Old version)
  • Logitech QuickCam (reserved id 0x046D:0x08B6)
  • Logitech QuickCam (reserved id 0x046D:0x08B7)
  • Logitech QuickCam (reserved id 0x046D:0x08B8)
  • Creative Labs Webcam 5 (Old version)
  • Creative Labs Webcam Pro Ex
  • Samsung MPC-C10
  • Samsung MPC-C30
  • Samsung SNC-35E
  • Visionite VCS-UM100
  • Visionite VCS-UC300
  • Askey VC010 type 1
  • Askey VC010 type 2
  • AME Co. Afina Eye
  • Sotec Afina Eye

/dev/video0
device node to access the driver

To watch the videostream of your webcam with mplayer:

mplayer -demuxer rawvideo -rawvideo fps=15:w=320:h=240:i420 /dev/video0

To record the videostream of your webcam with mencoder:

mencoder -demuxer rawvideo -rawvideo fps=15:w=320:h=240:i420 /dev/video0 -ovc lavc -lavcopts vcodec=mpeg4 -o webcam.avi

Note: Both examples assume you have already set your webcam size to 'sif' and fps to 15. This can be done with pwcview(1): pwcview -h -s sif -f 15

The driver's website:
http://raaf.atspace.org/

pwcview(1)

This is free software licensed under the GPLv2; There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Copyright (C) 2006 Raaf

Based on the Linux pwc driver:

Copyright (C) 1999-2003 Nemosoft Unv.
Copyright (C) 2004-2006 Luc Saillard

Februari 17, 2006 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.