GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUILD.LIB.MK(5) FreeBSD File Formats Manual BUILD.LIB.MK(5)

build.lib.mk
bsdbuild - compilation of libraries

.include <bsd.lib.mk>

The build.lib.mk module compiles static and/or shared libraries from a set of source files. For shared libraries, it uses a bundled copy of GNU libtool. The module provides built-in support for sources in the following languages:
  • C (*.c)
  • C++ (*.cc or *.cpp)
  • Objective C (*.m)
  • Assembler (*.asm)
  • Lex (*.l)
  • Yacc (*.y)

lib${LIB}.a
Compile the source files into a static library.
lib${LIB}.la
Compile the source files into static and shared libraries using libtool (libtool comes bundled with BSDBuild).
clean-lib
Clean up object and library files.
cleandir-lib
Clean up for packaging.
install-lib
Install library files to the target installation directory (see csoft.common.mk(5)).
deinstall-lib
Uninstall libraries from the installation directory.

Name of target library. Platform-specific transforms will be applied to the name.
Target installation directory for libraries (usually set by configure).
If set to Yes, the install target will install the library files, otherwise it will be a no-op. Defaults to No.
If set to Yes, a shared library will be built. Default is No.
If set to Yes, a dlopen(3) compatible module will be built. Default is No.
A Global Unique Identifier (GUID) for the library. Exact interpretation is platform-specific.
Major version number for shared libraries.
Minor version number for shared libraries.
Revision number for shared libraries.
Specify other libraries to link against this library. Bare filename arguments are interpreted as archive files ("foo.a" or "foo.la"). Arguments of the form "-L/path/to/dir" and "-lfoo" specify shared libraries.
If set to Yes, use libtool(1) to build the libraries. If set to No, generate the library using the traditional method involving ar(1), ranlib(1), and -fPIC.
Path to GNU libtool(1). This is usually set by the configure script. BSDBuild-generated configure scripts will select BSDBuild's bundled copy of libtool by default (recommended), but an alternate libtool may be specified using --with-libtool=PATH.
Specify general libtool arguments (passed before --mode). Defaults to "--quiet".
Specify extra libtool arguments for linking of shared libraries.
Specify extra libtool arguments for linking of static libraries.
Compiler for C, C++ and Objective C sources. Defaults to the CC environment variable, or "cc".
Compiler flags for C sources. Defaults to the CFLAGS environment variable.
Compiler flags for C++ sources. Defaults to the CXXFLAGS environment variable.
Compiler flags for Objective C sources. Defaults to ‘${CFLAGS}’.
Compiler preprocessor flags, for sources in all languages featuring a C preprocessor.
Compiler for assembler sources. Defaults to ‘nasm’.
Compiler flags for assembler. Defaults to ‘-g -w-orphan-labels’.
Path to the lex(1) lexical analyzer generator.
Path to the yacc(1) parser generator.
Options for lex(1), defaults to ‘’.
Options for yacc(1), defaults to ‘-d’.
Libraries to use for Lex lexers. Defaults to ‘-ll’.
(Specific to the win32 platform) Path to the windres(1) utility, which generates windows resource files.
(Specific to the win32 platform) Resource file to use with windres(1).
List of data files to install into ${DATADIR}. The files must have been generated from the build process (i.e., if using a separate build with --srcdir, the specified files must exist in the build directory).
Files to install into ${DATADIR}. This variable is handled similarly to DATAFILES, except that the specified files must exist in the source directory.
Library header files will be installed into this directory. See build.common.mk(5).
List of library header files.
System-wide configuration files will be installed into this directory. It is usually set relative to ‘${SYSCONFDIR}’, for example ‘${SYSCONFDIR}/MyLibrary’.
List of configuration files to install into ${CONFDIR}. Note that the install target will not override existing configuration files, instead it will output a “The following configuration files have been preserved” message.
Overwrite any existing configuration file on installation. Default is "No".

build.common.mk(5), build.prog.mk(5)

build.lib.mk first appeared in BSDBuild 1.0.

BSDBuild is based on the 4.4BSD build system.

July 18, 2007 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 5 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.