GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUILD.PROG.MK(5) FreeBSD File Formats Manual BUILD.PROG.MK(5)

build.prog.mk
bsdbuild - compilation of executables

.include <bsd.prog.mk>

The build.prog.mk module is used to compile an executable program from a set of source files. The module provides built-in support for sources in the following languages:
  • C (*.c)
  • C++ (*.cc or *.cpp)
  • Objective C (*.m)
  • Assembler (*.asm)
  • Lex (*.l)
  • Yacc (*.y)

${PROG}
Compile/link the ${PROG} executable from the specified source files.
${GMONOUT}
Compile/link a profiled version of ${PROG}.
clean-prog
Clean up object and executable files.
cleandir-prog
Clean up for packaging.
install-prog
Install program to the target installation directory (see csoft.common.mk(5)).
deinstall-prog
Uninstall program from the installation directory.

Filename of target executable. Platform-specific transforms may be applied to the name.
Type of application. Set to ‘CLI’ for a command-line utility, ‘GUI’ for a graphical interface and ‘DAEMON’ for a server program. Defaults to ‘CLI’. The interpretation of this setting is platform-specific. On the Windows platform, this instructs the compiler to select the appropriate PE header subsystem.
Target installation directory for executables (usually set by configure).
If set to ‘Yes’, the install target will install the program, otherwise it will be a no-op. Defaults to ‘Yes’.
A Global Unique Identifier (GUID) for the program. Exact interpretation is platform-specific.
Output filename for profiled version of the program.
Compiler for C, C++ and Objective C sources. Defaults to ‘cc’.
Compiler flags for C sources. Defaults to ‘-O2 -g’.
Compiler flags for C++ sources. Defaults to ‘’.
Compiler flags for Objective C sources. Defaults to ‘${CFLAGS}’.
Compiler preprocessor flags, for sources in all languages featuring a C preprocessor.
Compiler for assembler sources. Defaults to ‘nasm’.
Compiler flags for assembler. Defaults to ‘-g -w-orphan-labels’.
Path to the lex(1) lexical analyzer generator.
Path to the yacc(1) parser generator.
Options for lex(1), defaults to ‘’.
Options for yacc(1), defaults to ‘-d’.
Libraries to use for Lex lexers. Defaults to ‘-ll’.
(Specific to the win32 platform) Path to the windres(1) utility, which generates windows resource files.
(Specific to the win32 platform) Resource file to use with windres(1).
List of data files to install into ${DATADIR}. The files must have been generated from the build process (i.e., if using a separate build with --srcdir, the specified files must exist in the build directory).
Files to install into ${DATADIR}. This variable is handled similarly to DATAFILES, except that the specified files must exist in the source directory.
System-wide configuration files will be installed into this directory. It is usually set relative to ‘${SYSCONFDIR}’, for example ‘${SYSCONFDIR}/MyApplication’.
List of configuration files to install into ${CONFDIR}. Note that the install target will not override existing configuration files, instead it will output a “The following configuration files have been preserved” message.
Overwrite any existing configuration file on installation. Default is "No".

build.common.mk(5), build.lib.mk(5)

build.prog.mk first appeared in BSDBuild 1.0.

BSDBuild is based on the 4.4BSD build system.

July 18, 2007 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 5 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.