GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
POUDRIERE-JAIL(8) FreeBSD System Manager's Manual POUDRIERE-JAIL(8)

poudriere-jail
manage jails used to build ports

poudriere jail -c -j name [-bDx] [-a architecture] [-f filesystem] [-J maxjobs] [-K kernelname] [-M mountpoint] [-m method] [-P patch] [-p portstree] [-S srcpath] [-z set]

poudriere jail -d -j name [-C data] [-p portstree] [-z set]

poudriere jail -i -j name [-z set]

poudriere jail -k -j name [-z set]

poudriere jail -l [nq] [-z set]

poudriere jail -r name -j name [-z set]

poudriere jail -s -j name [-z set]

poudriere jail -u -j name [-x] [-J maxjobs] [-t version] [-z set]

This command manages the poudriere-jail jails which are used as different building environments.

Create a jail. See CAVEATS for restrictions on the names of jails.
Delete a jail.

If the stdin is a TTY then the command is going to ask for confirmation, which defaults to “N” (for no). Othwerwise, the specified jail is deleted without confirmation.

Show information about a jail. See also poudriere-status(8).
Kill a jail (stop it).
List all poudriere jails.
name
Rename a jail to name.
Start a jail.
Update a jail.

Except for -l, all of the subcommands require the -j option (see below).
architecture
Specify the architecture to use in the jail (for example amd64). The default is the architecture of the host.
Build the source provided with the -m src=path option.
data
Clean poudriere data folders when deleting a jail. Only used for -d option.

The data parameter can be one of the following: all, cache, logs, packages, or wkrdirs.

Clone the Git repository with the full history when creating the jail from a Git checkout. The default behavior is to check out only the most recent commit (as if --depth=1 was specified to the Git command).
filesystem
Specify the filesystem name (${ZPOOL}/jails/filesystem).
maxjobs
Run maxjobs of make(1) jobs in parallel for buildworld. Defaults to the number of CPUs reported by: “sysctl hw.ncpu”.
name
Specify the name of the jail.
kernelname
Install the jail with the specified kernel name. If the kernelname is an empty string then GENERIC will be used. If installing from FTP then the default kernel is installed and the value of kernelname is ignored.
mountpoint
Use an alternative mountpoint when creating the jail.
method
Specify which method to use to create the jail. The default is http.

Pre-built distribution options:

Fetch from http://www.allbsd.org.
Fetch from the host specified in the FREEBSD_HOST variable in poudriere.conf.
Fetch from http://ftp-archive.freebsd.org.
See ftp.
Fetch from https://artifact.ci.freebsd.org.
This option can be used to import an existing directory that already contains an installed system. The path must be specified with -M path. It is expected that this directory be installed to with the following:
# cd /usr/src

#
 make installworld DESTDIR=
PATH
 DB_FROM_SRC=1

# make distrib-dirs DESTDIR=
PATH
 DB_FROM_SRC=1

# make distribution DESTDIR=
PATH
 DB_FROM_SRC=1

        

It will not be copied at the time of running “poudriere jail”. Deleting the jail will attempt to revert any files changed by poudriere.

path
Install from the given directory at path. This directory will not be built from. It is expected that it is already built and maps to a corresponding /usr/obj directory.
path
Install from the tarball located at the given path.

Note that if you plan to build any port containing kernel modules then the specified tarball has to contain the /usr/src files as well.

url
Fetch distribution tarballs (like base.txz) from the given url. Any URL supported by fetch(1) can be used. For example: “url=file:///mirror/10.0”.

Build from source options:

[+protocol]
Use Git to download the sources.

Sources will be cloned shallowly unless -D is specified.

Output will mostly be hidden unless poudriere -v jail is used.

Use the -v branch parameter to set the branch name when creating a jail.

Use the -t branch parameter to switch the branch when updating a jail.

The Git server address is derived from the GIT_BASEURL variable in poudriere.conf. -U url may be used to override that value.

The following protocols are supported: git (default), +http, +https, +file, +ssh.

path
Copy the source tree from path into the jail, and build it. This option is meant to be used with the -b flag.
[+protocol]
Use SVN to download the sources.

Output will mostly be hidden unless poudriere -v jail is used.

Use the -v branch parameter to set the branch name.

Use the -t branch parameter to switch the branch when updating a jail.

The SVN host address is derived from the SVN_HOST variable in poudriere.conf. -U url may be used to override that value.

The following protocols are supported: svn (default), +http, +https, +file, +ssh.

When combined with -l, only display jail name.
patch
Apply the specified patch to the source tree before building the jail.
portstree
Specify the ports tree to start/stop the jail with.
Remove the header when -l is the specified mandatory option. Otherwise, it has no effect.
srcpath
Use the specified srcpath as the FreeBSD source tree mounted inside the jail or from the host for -m null.
version
Upgrade the jail to the specified version instead of upgrading to the latest security fix.
url
Specifies which url to checkout from when using the git or svn methods.
version
Specify the version of FreeBSD to use in the jail. If you are using -m ftp then the version should in the form of “12.0-RELEASE”. If you are using -m git, or -m svn, then the version should be in the form of Git or SVN branches, which is usually in the form of “stable/9” or “main” for CURRENT from git. Other methods only use the version value for display.
Build the native-xtools target using the host's /usr/src tree and copy this into the jail. The use of /usr/src is due to a bug in the native-xtools build which does not allow it to be built from the jail's own source. Used exclusively for cross building a ports set, typically via the qemu-user tools.
set
This specifies which set to start/stop the jail with.

The jail subcommand may use the following environment variables:
The bind address used by fetch(1). See fetch(3) for more details.
*
The proxy configuration for fetch(1). See fetch(3) for other supported proxy environment variables.
*
See FTP_*⟩.
See FTP_*⟩.
*
See FTP_*⟩.
*
See FTP_*⟩.
See FTP_*⟩.
See FTP_*⟩.
See FTP_*⟩.
*
See FTP_*⟩.
Related to the -x flag. See build(7) and the implementation of the jail subcommand for more details.

Example 1: Creating New Jail

The following example creates a new amd64 jail called “120amd64”, that is based on FreeBSD 12.0-RELEASE.

#
 poudriere jail -c -j 120amd64 -v 12.0-RELEASE -a amd64

    
Example 2: Checking If a Jail Already Exists

The following command returns success if a poudriere jail called “112i386” already exists.

#
 poudriere jail -l -n -q
 | grep --quiet '^112i386$'

    

jail(8), poudriere(8), poudriere-bulk(8), poudriere-distclean(8), poudriere-image(8), poudriere-logclean(8), poudriere-options(8), poudriere-pkgclean(8), poudriere-ports(8), poudriere-queue(8), poudriere-status(8), poudriere-testport(8), poudriere-version(8)

Baptiste Daroussin ⟨bapt@FreeBSD.org⟩
Bryan Drewery ⟨bdrewery@FreeBSD.org⟩

The values set with the -j, -z, and -p flags are all used directly in the name of the jail created by poudriere.

Be careful to respect the names supported by jail(8):

This is an arbitrary string that identifies a jail (except it
may not contain a '.').
August 13, 2021 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 8 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.