GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUF_ISLOCKED(9) FreeBSD Kernel Developer's Manual BUF_ISLOCKED(9)

BUF_ISLOCKED
returns the state of the lock linked to the buffer

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/uio.h>
#include <sys/bio.h>
#include <sys/buf.h>

int
BUF_ISLOCKED(struct buf *bp);

The BUF_ISLOCKED() function returns the status of the lock linked to the buffer in relation to curthread.

It can return:

An exclusive lock is held by curthread.
An exclusive lock is held by someone other than curthread.
A shared lock is held.
The lock is not held by anyone.

buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9), lockstatus(9)

This manual page was written by Attilio Rao <attilio@FreeBSD.org>.
January 22, 2008 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.