GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUF_RECURSED(9) FreeBSD Kernel Developer's Manual BUF_RECURSED(9)

BUF_RECURSED
checks if the lock linked to the buffer is recursed

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/uio.h>
#include <sys/bio.h>
#include <sys/buf.h>

int
BUF_RECURSED(struct buf *bp);

The BUF_RECURSED() function checks if the lock linked to the given buffer is recursed and returns 1 if the condition is true, 0 otherwise.

Its argument is:

bp
The buffer linked to the lock. See lockmgr_recursed(9) for details.

buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)

This manual page was written by Attilio Rao <attilio@FreeBSD.org>.
January 22, 2008 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.