GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
CTASSERT(9) FreeBSD Kernel Developer's Manual CTASSERT(9)

CTASSERT
compile time assertion macro

#include <sys/param.h>
#include <sys/systm.h>

CTASSERT(expression);

The CTASSERT() macro is deprecated and the C11 standard _Static_assert() should be used instead. The header sys/cdefs.h should be included to provide compatibility for pre-C11 compilers.

The CTASSERT() macro evaluates expression at compile time and causes a compiler error if it is false.

The CTASSERT() macro is useful for asserting the size or alignment of important data structures and variables during compilation, which would otherwise cause the code to fail at run time.

Assert that the size of the uuid structure is 16 bytes.

CTASSERT(sizeof(struct uuid) == 16);

KASSERT(9)

This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
August 1, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.