GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_DETACH(9) FreeBSD Kernel Developer's Manual DEVICE_DETACH(9)

DEVICE_DETACH
detach a device

#include <sys/param.h>
#include <sys/bus.h>

int
DEVICE_DETACH(device_t dev);

Detach a device. This can be called if the user is replacing the driver software or if a device is about to be physically removed from the system (e.g. for pccard(4) devices).

The method should deallocate any system resources allocated during the DEVICE_ATTACH(9) method and reset the hardware to a sane state (i.e., disable interrupts etc.)

Zero is returned on success, otherwise an appropriate error is returned.

pccard(4), device(9), DEVICE_ATTACH(9), DEVICE_IDENTIFY(9), DEVICE_PROBE(9), DEVICE_SHUTDOWN(9)

This manual page was written by Doug Rabson.
June 16, 1998 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.