GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_FIND_CHILD(9) FreeBSD Kernel Developer's Manual DEVICE_FIND_CHILD(9)

device_find_child
search for a child of a device

#include <sys/param.h>
#include <sys/bus.h>

device_t
device_find_child(device_t dev, const char *classname, int unit);

This function looks for a specific child of dev with the given classname and unit. If unit is -1, it returns the first child of dev with a matching classname (that is, the one with the lowest unit).

If it exists, the child device is returned, otherwise NULL.

device_add_child(9)

This manual page was written by Doug Rabson.
February 8, 2005 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.