GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_GET_SYSCTL(9) FreeBSD Kernel Developer's Manual DEVICE_GET_SYSCTL(9)

device_get_sysctl_ctx, device_get_sysctl_tree
manipulate the sysctl oid tree for driver specific sysctl nodes

#include <sys/param.h>
#include <sys/bus.h>

struct sysctl_ctx_list *
device_get_sysctl_ctx(device_t dev);

struct sysctl_oid *
device_get_sysctl_tree(device_t dev);

The newbus system automatically adds a sysctl node for each device in the system. This node can be accessed with the device_get_sysctl_tree() function. The context for the node can be obtained with the device_get_sysctl_ctx() function.

device(9)

This manual page was written by Warner Losh.
June 18, 2011 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.