GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_QUIET(9) FreeBSD Kernel Developer's Manual DEVICE_QUIET(9)

device_quiet, device_verbose, device_is_quiet
manipulate device quiet flag

#include <sys/param.h>
#include <sys/bus.h>

void
device_quiet(device_t dev);

void
device_verbose(device_t dev);

int
device_is_quiet(device_t dev);

Each device has a quiet flag associated with it. A device is verbose by default when it is created but may be quieted to prevent printing of the device identification string during attach and printing of a message during detach. To quiet a device, call device_quiet() during a device driver probe routine. To re-enable probe messages, call device_verbose(). To test to see if a device is quieted, call device_is_quiet().

Devices are implicitly marked verbose after a driver detaches.

device(9)

This manual page was written by Doug Rabson.
September 12, 2016 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.