GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
GETNEWVNODE(9) FreeBSD Kernel Developer's Manual GETNEWVNODE(9)

getnewvnode
get a new vnode

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/mount.h>

int
getnewvnode(const char *tag, struct mount *mp, vop_t **vops, struct vnode **vpp);

The getnewvnode() function initializes a new vnode, assigning it the vnode operations passed in vops. The vnode is either freshly allocated, or taken from the head of the free list depending on the number of vnodes already in the system.

The arguments to getnewvnode() are:

tag
The file system type string. This field should only be referenced for debugging or for userland utilities.
mp
The mount point to add the new vnode to.
vops
The vnode operations to assign to the new vnode.
vpp
Points to the new vnode upon successful completion.

getnewvnode() returns 0 on success. There are currently no failure conditions - that do not result in a panic.

This manual page was written by Chad David <davidc@acns.ab.ca>.
November 21, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.