GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
MD5(9) FreeBSD Kernel Developer's Manual MD5(9)

MD5, MD5Init, MD5Transform
message digest routines

#include <sys/types.h>
#include <sys/md5.h>

void
MD5Init(MD5_CTX *buf);

void
MD5Transform(uint32_t buf[4], const unsigned char block[64]);

The MD5 module implements the RSA Data Security, Inc. MD5 Message-Digest Algorithm (MD5). It produces 128-bit MD5 Digest of data.
MD5Init
must be called just before MD5Transform() will be used to produce a digest. The buf argument is the storage for the digest being produced on subsequent calls to the MD5Transform() routine.
MD5Transform
is the core of the MD5 algorithm, this alters an existing MD5 hash kept in buf to reflect the addition of 64 characters of new data passed in block argument.

The code for MD5 transform was taken from Colin Plumb's implementation, which has been placed in the public domain. The MD5 cryptographic checksum was devised by Ronald Rivest, and is documented in RFC 1321, "The MD5 Message Digest Algorithm".
April 17, 1996 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.