GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PCI_IOV_UNINIT(9) FreeBSD Kernel Developer's Manual PCI_IOV_UNINIT(9)

PCI_IOV_UNINIT
disable SR-IOV on a PF device

#include <sys/bus.h>
#include <dev/pci/pci_iov.h>

void
PCI_IOV_UNINIT(device_t dev);

The PCI_IOV_UNINIT() method is called by the PCI Single-Root I/O Virtualization (SR-IOV) infrastructure when the user requests that SR-IOV be disabled on a Physical Function (PF). When this method is called, the PF driver must release any SR-IOV-related resources that it has allocated and disable any device-specific SR-IOV configuration in the device.

This method will only be called following a successful call to PCI_IOV_INIT(9). It is not guaranteed that PCI_IOV_ADD_VF(9) will have been called for any Virtual Function (VF) after the call to PCI_IOV_INIT(9) and before the call to PCI_IOV_UNINIT.

pci(9), PCI_IOV_ADD_VF(9), PCI_IOV_INIT(9)

This manual page was written by Ryan Stone <rstone@FreeBSD.org>.
May 28, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.