GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
SECURELEVEL_GT(9) FreeBSD Kernel Developer's Manual SECURELEVEL_GT(9)

securelevel_gt, securelevel_ge
test active securelevel

#include <sys/types.h>
#include <sys/proc.h>

int
securelevel_gt(struct ucred *cr, int level);

int
securelevel_ge(struct ucred *cr, int level);

These functions test the active security level against the given level. If the calling credential cr was imprisoned by the jail(2) system call, and has a different security level set than the host environment, the security level with the highest value is used.

The securelevel_gt() function will evaluate whether or not the active security level is greater than the supplied level.

The securelevel_ge() function will evaluate whether or not the active security level is greater than or equal to the supplied level.

These functions return EPERM if condition evaluated to true, and 0 otherwise.

securelevel(7)
June 2, 2007 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.