GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_BUSY(9) FreeBSD Kernel Developer's Manual VFS_BUSY(9)

vfs_busy
marks a mount point as busy

#include <sys/param.h>
#include <sys/mount.h>

int
vfs_busy(struct mount *mp, int flags);

The vfs_busy() function marks a mount point as busy by incrementing the reference count of a mount point. It also delays unmounting by sleeping on mp if the MNTK_UNMOUNT flag is set in mp->mnt_kern_flag and the MBF_NOWAIT flag is not set.

Its arguments are:

mp
The mount point to busy.
flags
Flags controlling how vfs_busy() should act.
do not sleep if MNTK_UNMOUNT is set.
drop the mountlist_mtx in the critical path.

A 0 value is returned on success. If the mount point is being unmounted and MBF_NOWAIT flag is specified ENOENT will be returned.

[]
The mount point is being unmounted (MNTK_UNMOUNT is set).

vfs_unbusy(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
February 11, 2013 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.