GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_MAP_MADVISE(9) FreeBSD Kernel Developer's Manual VM_MAP_MADVISE(9)

vm_map_madvise
apply advice about use of memory to map entries

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_map.h>

int
vm_map_madvise(vm_map_t map, vm_offset_t start, vm_offset_t end, int behav);

The vm_map_madvise() function applies the flags behav to the entries within map between start and end.

Advisories are classified as either those affecting the vm_map_entry structure, or those affecting the underlying objects.

The vm_map_madvise() function is used by the madvise(2) system call.

The vm_map_madvise() function returns 0 if successful. If the behav argument was not recognised, KERN_INVALID_ARGUMENT is returned.

madvise(2), vm_map(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 19, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.