GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_PAGE_RENAME(9) FreeBSD Kernel Developer's Manual VM_PAGE_RENAME(9)

vm_page_rename
move a page

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>

void
vm_page_rename(vm_page_t m, vm_object_t new_object, vm_pindex_t new_pindex);

The vm_page_rename() function removes a page from one object, and adds it to another at the given page index. The page is added to the given object, and is removed from the object that is currently associated with. If the page is currently on the cache queue it will be deactivated unless it is wired or unmanaged, in which case the deactivation will fail. The entire page is marked as dirty after the move.

The arguments to vm_page_rename() are:

m
The page to move.
new_object
The object the page should be inserted into.
new_pindex
The page index into new_object at which the new page should be inserted.

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 17, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.