GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_ADVLOCK(9) FreeBSD Kernel Developer's Manual VOP_ADVLOCK(9)

VOP_ADVLOCK
advisory record locking

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/fcntl.h>
#include <sys/lockf.h>

int
VOP_ADVLOCK(struct vnode *vp, caddr_t id, int op, struct flock *fl, int flags);

The arguments are:
vp
The vnode being manipulated.
id
The id token which is changing the lock.
op
The operation to perform (see fcntl(2)).
fl
Description of the lock.
flags
One or more of the following:

Wait until lock is granted.
Use flock(2) semantics for lock.
Use POSIX semantics for lock.
Lock owner is remote NFS client.
Mask signals while waiting for the lock.

This entry point manipulates advisory record locks on the file. Most file systems delegate the work for this call to lf_advlock().

Zero is returned on success, otherwise an error is returned.

fcntl(2), flock(2), vnode(9)

This manual page was written by Doug Rabson.
February 10, 2021 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.