GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_PATHCONF(9) FreeBSD Kernel Developer's Manual VOP_PATHCONF(9)

VOP_PATHCONF
return POSIX pathconf information

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/unistd.h>

int
VOP_PATHCONF(struct vnode *vp, int name, long *retval);

The arguments are:
vp
The vnode to get information about.
name
The type of information to return.
retval
The place to return the information.

The value of name specifies what should be returned:

The maximum number of links to a file.
The maximum number of bytes in a file name.
The maximum number of bytes in a pathname.
The maximum number of bytes which will be written atomically to a pipe.
Return 1 if appropriate privileges are required for the chown(2) system call, otherwise 0.
Return 1 if file names longer than KERN_NAME_MAX are truncated.

The vnode will be locked on entry and should remain locked on return.

If name is recognized, *retval is set to the specified value and zero is returned, otherwise EINVAL is returned.

pathconf(2), vnode(9)

This manual page was written by Doug Rabson.
December 31, 2020 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.