GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_RDWR(9) FreeBSD Kernel Developer's Manual VOP_RDWR(9)

VOP_READ, VOP_WRITE
read or write a file

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/uio.h>

int
VOP_READ(struct vnode *vp, struct uio *uio, int ioflag, struct ucred *cred);

int
VOP_WRITE(struct vnode *vp, struct uio *uio, int ioflag, struct ucred *cred);

These entry points read or write the contents of a file.

The arguments are:

vp
The vnode of the file.
uio
The location of the data to be read or written.
ioflag
Various flags.
cnp
The credentials of the caller.

The ioflag argument is used to give directives and hints to the file system. When attempting a read, the high 16 bits are used to provide a read-ahead hint (in units of file system blocks) that the file system should attempt. The low 16 bits are a bit mask which can contain the following flags:

Do I/O as atomic unit.
Append write to end.
Do I/O synchronously.
Underlying node already locked.
flag set in file table.
Data already in VMIO space.

The file should be locked on entry and will still be locked on exit. Rangelock covering the whole i/o range should be owned around the call.

Zero is returned on success, otherwise an error code is returned.

[]
An attempt was made to write a file that exceeds the process's file size limit or the maximum file size.
[]
The file system is full.
[]
An append-only flag is set on the file, but the caller is attempting to write before the current end of file.

uiomove(9), vnode(9)

This manual page was written by Doug Rabson.
July 24, 1996 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.