GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_REVOKE(9) FreeBSD Kernel Developer's Manual VOP_REVOKE(9)

VOP_REVOKE
revoke access to a device and its aliases

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_REVOKE(struct vnode *vp, int flags);

VOP_REVOKE() will administratively revoke access to the device specified by vp, as well as any aliases created via make_dev_alias(9). Further file operations on any of these devices by processes which have them open will nominally fail. The flags must be set to REVOKEALL to signify that all access will be revoked; any other value is invalid.

The vp must be exclusively locked on entry, and will remain locked upon return.

make_dev_alias(9), vnode(9)

This manual page was written by Brian Fundakowski Feldman.
June 20, 2019 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.