GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_VPTOFH(9) FreeBSD Kernel Developer's Manual VOP_VPTOFH(9)

VOP_VPTOFH
turn a vnode into an NFS filehandle

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_VPTOFH(struct vnode *vp, struct fid *fhp);

This is used by the NFS server to create an opaque filehandle which uniquely identifies the file and which can be used by an NFS client to access the file in the future.

Its arguments are:

vp
The vnode to make a filehandle for.
fhp
Return parameter for the filehandle.

VFS(9), VFS_FHTOVP(9), vnode(9)

This manual page was written by Doug Rabson.
February 16, 2007 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.