GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
WATCHDOG(9) FreeBSD Kernel Developer's Manual WATCHDOG(9)

watchdog
software and hardware watchdog facility

#include <sys/watchdog.h>

void
watchdog_fn(void *private, u_int cmd, int *error);

EVENTHANDLER_REGISTER(watchdog_list, watchdog_fn, private, 0);

EVENTHANDLER_DEREGISTER(watchdog_list, eventhandler_tag);

To implement a watchdog in software or hardware, only a single function needs to be written and registered on the global watchdog_list.

The function must examine the cmd argument and act on it as follows:

If cmd is zero, the watchdog must be disabled and the error argument left untouched. If the watchdog cannot be disabled, the error argument must be set to EOPNOTSUPP.

Else the watchdog should be reset and configured to a timeout of (1 << (cmd & WD_INTERVAL)) nanoseconds or larger and the error argument be set to zero to signal arming of a watchdog.

If the watchdog cannot be configured to the proposed timeout, it must be disabled and the error argument left as is (to avoid hiding the arming of another watchdog).

There is no specification of what the watchdog should do when it times out, but a hardware reset or similar “drastic but certain” behaviour is recommended.

watchdog(4)

The watchdog facility and this manual page was written Poul-Henning Kamp <phk@FreeBSD.org>.
February 28, 2004 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.