GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVCLASS_GET_DEVICES(9) FreeBSD Kernel Developer's Manual DEVCLASS_GET_DEVICES(9)

devclass_get_devices
get a list of devices in a devclass

#include <sys/param.h>
#include <sys/bus.h>

int
devclass_get_devices(devclass_t dc, device_t **devlistp, int *devcountp);

Retrieve a list of all device instances currently in the devclass and return the list in *devlistp and the count in *devcountp. The memory allocated for the list should be freed using free(*devlistp, M_TEMP), even if *devcountp is 0.

Zero is returned on success, otherwise an appropriate error is returned.

devclass(9), device(9)

This manual page was written by Doug Rabson.
May 19, 2005 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.