GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PGFIND(9) FreeBSD Kernel Developer's Manual PGFIND(9)

pgfind
locate a process group by number

#include <sys/param.h>
#include <sys/proc.h>

struct pgrp *
pgfind(pid_t pgid);

The pgfind() function takes a pgid as its argument and returns a pointer to the pgrp structure whose pg_id is specified in the argument.

pgfind() locks the pgrp structure that is returned.

The pgfind() function returns NULL on failure or a pointer to a pgrp structure on successful completion.

pfind(9)

This manual page was written by Evan Sarmiento <kaworu@sektor7.ath.cx>.
August 8, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.