GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_IS_MODIFIED(9) FreeBSD Kernel Developer's Manual PMAP_IS_MODIFIED(9)

pmap_is_modified, pmap_ts_modified
return information about physical pages

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

boolean_t
pmap_is_modified(vm_page_t m);

int
pmap_ts_referenced(vm_page_t m);

The pmap_is_modified() and pmap_ts_referenced() functions return information about physical pages.

The pmap_is_modified() function returns the status of the “page modified” bit for the physical page m.

The pmap_ts_referenced() function returns a count of reference bits for a page m, clearing those bits. It is not necessary for every reference bit to be cleared, but it is necessary that 0 only be returned when there are no remaining reference bits set on the page.

pmap(9), pmap_clear_modify(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 17, 2014 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.