GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_MINCORE(9) FreeBSD Kernel Developer's Manual PMAP_MINCORE(9)

pmap_mincore
determine if a virtual address is resident in physical memory

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

int
pmap_mincore(pmap_t pmap, vm_offset_t addr);

The pmap_mincore() function determines if the page at the virtual address addr in the physical map pmap is resident in physical memory. It is the machine-dependent interface used by the mincore(2) system call.

If the page is resident in physical memory, a mask of flags is returned, whose meaning is documented in mincore(2); otherwise, 0 is returned.

The pmap must exist and addr must be mapped into the pmap. If any error occurs, the machine-dependent implementation should return 0.

mincore(2), pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 21, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.