GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_OBJECT_INIT_PT(9) FreeBSD Kernel Developer's Manual PMAP_OBJECT_INIT_PT(9)

pmap_object_init_pt
initialize page tables for a VM object

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_object_init_pt(pmap_t pmap, vm_offset_t addr, vm_object_t object, vm_pindex_t pindex, vm_size_t size, int limit);

The pmap_object_init_pt() function preloads the page table entries into the specified physical map pmap, for the given object at the virtual address addr, for size bytes, beginning at the page index pindex within the object. The map bits limit are heeded when creating the mapping.

This function is not strictly required by an architecture's pmap(9) implementation, but it does provide performance benefits if implemented.

It is intended to eliminate the blast of soft faults on process startup, and immediately following a call to mmap(2).

pmap(9), vm_map(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 21, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.