GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_PROTECT(9) FreeBSD Kernel Developer's Manual PMAP_PROTECT(9)

pmap_protect
set physical page protection

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_protect(pmap_t pmap, vm_offset_t sva, vm_offset_t eva, vm_prot_t prot);

The pmap_protect() function sets the physical page permissions to prot for all physical pages in the physical map pmap in the virtual address range between sva and eva.

pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 18, 2014 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.