GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_UNWIRE(9) FreeBSD Kernel Developer's Manual PMAP_UNWIRE(9)

pmap_unwire
unwire a range of virtual pages

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_unwire(pmap_t pmap, vm_offset_t start, vm_offset_t end);

The function pmap_unwire() removes the wired attribute from each of the virtual-to-physical page mappings within the virtual address range from start to end of the physical map pmap. Every valid mapping within that range is required to have the wired attribute set. Invalid mappings are ignored, since they cannot have the wired attribute set.

Only the function pmap_enter(9) can be used to set the wired attribute of a virtual-to-physical page mapping.

pmap(9), pmap_enter(9), pmap_wired_count(9)

This manual page was written by Alan L. Cox ⟨alc@rice.edu⟩.
July 17, 2014 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.