GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
THREAD_EXIT(9) FreeBSD Kernel Developer's Manual THREAD_EXIT(9)

thread_exit
abandon current thread context

#include <sys/param.h>
#include <sys/proc.h>

void
thread_exit(void);

The thread_exit() function implements the machine independent prelude to a thread shutdown. It will not return, and will result in a call to mi_switch(9) to schedule some other thread.

thread_exit() arranges to free all the resources of the thread, specifically the kernel stack.

To protect the runqueue(9), thread_exit() must be called with the sched_lock mutex held.

mi_switch(9), mutex(9), runqueue(9), sleep(9)
July 5, 2002 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.