GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_MAP_REMOVE(9) FreeBSD Kernel Developer's Manual VM_MAP_REMOVE(9)

vm_map_remove
remove a virtual address range from a map

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_map.h>

int
vm_map_remove(vm_map_t map, vm_offset_t start, vm_offset_t end);

The vm_map_remove() function removes the given address range bounded by start and end from the target map.

This is the exported form of vm_map_delete(9) which may be called by consumers of the VM subsystem.

The function calls vm_map_lock(9) to hold a lock on map for the duration of the function call.

The vm_map_remove() always returns KERN_SUCCESS.

vm_map(9), vm_map_delete(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 19, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.