GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_MAP_SIMPLIFY_ENTRY(9) FreeBSD Kernel Developer's Manual VM_MAP_SIMPLIFY_ENTRY(9)

vm_map_simplify_entry
simplify a vm_map_entry

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_map.h>

void
vm_map_simplify_entry(vm_map_t map, vm_map_entry_t entry);

The vm_map_simplify_entry() function simplifies the given entry by merging with either neighbour. The map must be locked upon entry.

This function also has the ability to merge with both neighbours.

This function guarantees that the passed entry remains valid, although possibly extended.

vm_map(9), vm_map_insert(9), vm_map_remove(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 19, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.