GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
SCREEN.LUA(8) FreeBSD System Manager's Manual SCREEN.LUA(8)

screen.lua
FreeBSD screen manipulation module

screen.lua contains functionality for manipulating the screen. This includes functionality such as clearing the screen, moving the cursor, and setting foreground/background colors using sequences provided by color.lua(8).

Before using the functionality provided by screen.lua, it must be included with a statement such as the following:

local screen = require("screen")

The following variables are exported from screen.lua:

The x component of the default cursor position.
The y component of the default cursor position.

The following functions are exported from screen.lua:

screen.clear()
Clears the screen. screen.clear() will do nothing if a serial boot is detected.
screen.setcursor(x, y)
Sets the cursor position to x, y. screen.setcursor() will do nothing if a serial boot is detected.
screen.setforeground(color_value)
Sets the foreground color to color_value, which should be a constant defined in color.lua(8). screen.setforeground() will do nothing if color is disabled.
screen.setbackground(color_value)
Sets the background color to color_value, which should be a constant defined in color.lua(8). screen.setbackground() will do nothing if color is disabled.
screen.defcolor()
Sets the default color scheme, as defined by color.default(). screen.defcolor() will do nothing if color is disabled.
screen.defcursor()
Sets the default cursor position to that defined by screen.default_x, screen.default_y.

color.lua(8)

The screen.lua file was originally written by Pedro Souza <pedrosouza@FreeBSD.org>. Later work and this manual page was done by
Kyle Evans <kevans@FreeBSD.org>.
August 19, 2018 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 8 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.