GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_SETEXTATTR(9) FreeBSD Kernel Developer's Manual VOP_SETEXTATTR(9)

VOP_SETEXTATTR
set named extended attribute for a vnode

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/extattr.h>

int
VOP_SETEXTATTR(struct vnode *vp, int attrnamespace, const char *name, struct uio *uio, struct ucred *cred, struct thread *td);

This vnode call may be used to set specific named extended attribute for a file or directory.

Its arguments are:

vp
The vnode of the file or directory.
attrnamespace
Integer constant indicating which extended attribute namespace the attribute name is present in.
name
Pointer to a null-terminated character string containing the attribute name.
uio
The location of the data to be read or written.
cred
The user credentials to use in authorizing the request.
td
The thread setting the extended attribute.

The uio structure is used in a manner similar to the argument of the same name in VOP_WRITE(9). However, as extended attributes provide a strict "name=value" semantic, non-zero offsets will be rejected.

The uio pointer may be NULL to indicate that the specified extended attribute should be deleted.

The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to allow the kernel to authorize extended attribute changes that the active process might not be permitted to make.

Extended attribute semantics may vary by file system implementing the call. More information on extended attributes may be found in extattr(9).

The vnode will be locked on entry and should remain locked on return.

If the extended attribute is successfully set, then zero is returned. Otherwise, an appropriate error code is returned.

[]
The caller does not have the appropriate privilege.
[]
The request was not valid in this file system for the specified vnode and attribute name.
[]
Insufficient memory available to fulfill the request.
[]
The uio structure refers to an invalid userspace address.
[]
The name, namespace, or uio argument is invalid.
[]
The file system does not support VOP_SETEXTATTR().
[]
The file system is out of space.
[]
The file system is read-only.

extattr(9), vnode(9), VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9)

This manual page was written by Robert Watson.
December 23, 1999 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.