GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_SET_DESC(9) FreeBSD Kernel Developer's Manual DEVICE_SET_DESC(9)

device_set_desc, device_set_desc_copy, device_get_desc
access the description of a device

#include <sys/param.h>
#include <sys/bus.h>

void
device_set_desc(device_t dev, const char *desc);

void
device_set_desc_copy(device_t dev, const char *desc);

const char *
device_get_desc(device_t dev);

Manipulate the verbose description of a device. This description (if present) is printed as part of the message when it is attached during autoconfiguration. The variation device_set_desc_copy() is used to set the description if the string passed is a temporary buffer which will be overwritten. In this case, the system will copy the string, otherwise the pointer passed will be used directly.

device(9)

This manual page was written by Doug Rabson.
June 16, 1998 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.