GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
G_ATTACH(9) FreeBSD Kernel Developer's Manual G_ATTACH(9)

g_attach, g_detach
attach/detach GEOM consumers to/from providers

#include <geom/geom.h>

int
g_attach(struct g_consumer *cp, struct g_provider *pp);

void
g_detach(struct g_consumer *cp);

The g_attach() function attaches given consumer cp to given provider pp, thus establishing a communication channel between the consumer and the provider that allows to change access counts and perform I/O operations.

The g_detach() function detaches given consumer cp from its corresponding provider, tearing down the communication channel between them.

g_attach():
  • The consumer must not be attached to a provider.
  • The operation must not create a topology loop.
  • The topology lock has to be held.

g_detach():

  • The consumer has to be attached.
  • The access count has to be 0.
  • There must be no active requests.
  • The topology lock has to be held.

The g_attach() function returns 0 if successful; otherwise an error code is returned.

Create a consumer, attach it to a given provider, gain read access and clean up.
void
some_function(struct g_geom *mygeom, struct g_provider *pp)
{
	struct g_consumer *cp;

	g_topology_assert();

	/* Create new consumer on 'mygeom' geom. */
	cp = g_new_consumer(mygeom);
	/* Attach newly created consumer to given provider. */
	if (g_attach(cp, pp) != 0) {
		g_destroy_consumer(cp);
		return;
	}
	/* Open provider for reading through our consumer. */
	if (g_access(cp, 1, 0, 0) != 0) {
		g_detach(cp);
		g_destroy_consumer(cp);
		return;
	}

	g_topology_unlock();
	/*
	 * Read data from provider.
	 */
	g_topology_lock();

	/* Disconnect from provider (release access count). */
	g_access(cp, -1, 0, 0);
	/* Detach from provider. */
	g_detach(cp);
	/* Destroy consumer. */
	g_destroy_consumer(cp);
}

Possible errors:
[]
The operation creates a topology loop.
[]
Provider got orphaned.

geom(4), DECLARE_GEOM_CLASS(9), g_access(9), g_bio(9), g_consumer(9), g_data(9), g_event(9), g_geom(9), g_provider(9), g_provider_by_name(9), g_wither_geom(9)

This manual page was written by Pawel Jakub Dawidek <pjd@FreeBSD.org>.
October 10, 2020 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.