GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
CP2112(4) FreeBSD Kernel Interfaces Manual CP2112(4)

cp2112
driver for a USB GPIO and I2C peripheral device

To compile this driver into the kernel, place the following lines in your kernel configuration file:
device cp2112
device usb
device gpio
device iicbus

Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):

cp2112_load="YES"

The cp2112 driver provides support for Silicon Labs CP2112 device. The device has 8 general purpose I/O pins and an I2C controller that supports a subset of the I2C protocol.

All pins support both input and output modes. An output pin can be configured either for open-drain or push-pull operation. Pins 0, 1 and 7 support special functions: I2C transmit indication, I2C receive indication and clock output respectively. At the moment the cp2112 driver does not provide a way to enable and configure the special functions.

The I2C controller supports read transactions with up to 512 bytes of data, write transactions with up to 61 bytes of data and a write followed by the repeated start followed by a read transactions where the write can be up to 16 bytes and the read can be up to 512 bytes. Zero length transfers are not supported. The cp2112 driver creates a gpio(4) and iicbus(4) child buses to expose the respective functions.

gpio(4), iicbus(4), usb(4)

The cp2112 driver and this manual page was written by Andriy Gapon <avg@FreeBSD.org>.
August 12, 2020 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.