GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
EFIDEV(4) FreeBSD Kernel Interfaces Manual EFIDEV(4)

efidev, efirtc
user-mode access to UEFI runtime services

To compile this driver into the kernel, place the following lines in your kernel configuration file:
options EFIRT

Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):

efirt_load="YES"

The driver may be disabled by setting the loader(8) tunable efi.rt.disabled to “1”.

The efidev device provides user-mode access to UEFI runtime services. efidev also includes a driver to provide a time-of-day clock using the UEFI real time clock (RTC). However, the RTC may not always be available, based on the UEFI firmware. If the RTC is not available, it will not be registered as a time-of-day clock and the time related ioctls below will not be functional.

efidev provides the following ioctls defined in <sys/efiio.h> with supplemental structures and constants defined in <sys/efi.h>:

(struct efi_get_table_ioc)
Get a table by uuid from the UEFI system table.
struct efi_get_table_ioc {
	struct uuid uuid;
	void *ptr;
};
    
(struct efi_tm)
Get the time from the RTC, if the RTC is available. The struct efi_tm passed is populated with the current time, unless an error occurs.
struct efi_tm {
	uint16_t	tm_year;
	uint8_t		tm_mon
	uint8_t		tm_mday
	uint8_t		tm_hour;
	uint8_t		tm_min;
	uint8_t		tm_sec;
	uint8_t		 __pad1;
	uint32_t	tm_nsec;
	int16_t		tm_tz;
	uint8_t		tm_dst;
	uint8_t		__pad2;
};
    
(struct efi_tm)
Sets the time stored by the RTC, if the RTC is available.
(struct efi_var_ioc)
Gets data from the variable described by the vendor and name fields of the struct efi_var_ioc into the data field. EFIIOC_VAR_GET (struct efi_var_ioc) will also populate the attrib field.
struct efi_var_ioc {
	efi_char	*name;
	size_t		 namesize;
	struct uuid	 vendor;
	uint32_t	 attrib;
	void		*data;
	size_t		 datasize;
};
    
(struct efi_var_ioc)
Used for enumerating all UEFI variables. The initial call should use an empty string for the name attribute. Subsequent calls should supply the vendor uuid and name of the last variable returned.
(struct efi_var_ioc)
Sets data and attributes for the variable described by the name and vendor in the struct efi_var_ioc.

/dev/efi
 

efivar(3), efirt(9)

A efidev device first appeared in FreeBSD 11.1.

efidev is currently only available on amd64 and arm64.
August 12, 2018 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.