GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
d4file(4) FreeBSD Kernel Interfaces Manual d4file(4)

d4file - D4-format binary file

d4file

The universal file format for storing the list of 4-tuple data. The file is called "D4-format file". D4-format file consists of two parts. A header with 256byte data is put on the head of file; a magic number for recognizing file format, an attribute code, the number of data, lower- and higher-limit of data are held in the header. Data part follows the header; list of 4-tuple data, the quadruple of 2-byte-integers (short), are put in the data part. Bit- and byte-order are MSB-first (big-endian). The file header is defined by the following structure.

struct d4file {
	char	d4_magic[8];	/* = "DATA0004" */
	int32	d4_attrb;	/* = 0 */
	int32	d4_count;	/* = 0 */
	short	d4_llimit[4];	/* lower  limit of each member */
	short	d4_hlimit[4];	/* higher limit of each member */
	short	d4_spc[48];	/* (filler) */
};

d4_magic field is always filled with string "DATA0004".

d4_attrb holds the attribute code of file. The attribute code is always 0.

d4_count holds the number of 4-tuple data. If this field is not used, constant 0 is set.

d4_llimit and d4_hlimit arrays hold lower- and higher-limits of 4-tuple data respectively.

d4_spc array is a dummy field, which is filled with zeros.

Each 4-tuple data is defined by the following structure.

struct d4pac {
	short	d4_data[4];
};

The real value held in d4_data can be either signed 2byte-integer (short) and unsigned 2byte-integer (unsigned short). The selection of the type depends on its application.

Copyright (C) 1995-1997 Hideaki Goto

E-Mail: hgot@ecip.tohoku.ac.jp, hgot@aso.ecei.tohoku.ac.jp

July 1997

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.