GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUILD.PROJ.MK(5) FreeBSD File Formats Manual BUILD.PROJ.MK(5)

build.proj.mk
bsdbuild - compilation of IDE project files

.include <bsd.proj.mk>

The build.proj.mk module uses the premake(1) utility to generate "project files", so that BSDBuild projects can be opened by various IDEs (Integrated Development Environments).

This module adds the target "proj", so that "make proj" will compile the project files, and pack them into sets of archive files (under PROJDIR, which defaults to "./ProjectFiles").

The various profiles are defined by the space-separated list PROJFILES. Each entry in PROJFILES has the format:

<OS>:<IDE>:<FLAVOR>:<OPTIONS>

"<OS>" specifies the operating system and "<IDE>" is the target IDE name. The "<FLAVOR> argument is a flavor or variant identifier (e.g., "nothreads"), and "<OPTIONS>" is a comma-separated list of ./configure options (e.g., "--disable-threads").

Valid "<OS>" values include:

windows
Windows 95 and up
windows-xp
Windows XP and up
windows-xp-x64
Windows XP and up (64-bit)
windows-vista
Windows Vista and up
windows-vista-x64
Windows Vista and up (64-bit)
windows-7
Windows 7 and up
windows-7-x64
Windows 7 and up (64-bit)

Note: Premake does support other targets ("bsd", "linux" and "macosx"), but it rarely if ever necessary to generate project files for those targets since they already provide a proper compilation environment (i.e., BSDBuild can be used directly on them).

Valid "<IDE>" target names include:

cb-gcc
Code::Blocks with gcc
vs6
Visual Studio 6
vs2002
Visual Studio 2002
vs2003
Visual Studio 2003
vs2005
Visual Studio 2005
monodev
MonoDevelop
sharpdev
ICSharpCode SharpDevelop

proj
If PROJECT is defined, generate the project files. Otherwise, only generate PREMAKEOUT in the current directory.

Name of project. If a project has multiple subdirectories, this should only be defined in the top-level directory.
List of project files to generate (see DESCRIPTION above).
Directory to hold generated project file archives.
List of additional files to include in all project file archives.
List of additional premake scripts to include everywhere.
Path to premake(1) utility.
Path to zip(1) utility.
Flags to zip(1).
Path to mkprojfiles(1) utility (which is part of BSDBuild).
Filename of premake input generated by BSDBuild (defaults to premake.lua).
Flags to premake utility.

build.common.mk(5), build.lib.mk(5), build.prog.mk(5)

build.proj.mk first appeared in BSDBuild 2.2

BSDBuild is based on the 4.4BSD build system.

November 24, 2007 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 5 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.