GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
waybar-memory(5) FreeBSD File Formats Manual waybar-memory(5)

waybar - memory module

The memory module displays the current memory utilization.

Addressed by memory

interval:
typeof: integer
default: 30
The interval in which the information gets polled.

format:
typeof: string
default: {percentage}%
The format, how information should be displayed.

format-icons:
typeof: array/object
Based on the current percentage, the corresponding icon gets selected.
The order is low to high. Or by the state if it is an object.

rotate:
typeof: integer
Positive value to rotate the text label.

states:
typeof: array
A number of memory utilization states which get activated on certain percentage thresholds. See waybar-states(5).

max-length:
typeof: integer
The maximum length in character the module should display.

min-length: typeof: integer The minimum length in characters the module should take up.

align: typeof: float The alignment of the text, where 0 is left-aligned and 1 is right-aligned. If the module is rotated, it will follow the flow of the text.

on-click:
typeof: string
Command to execute when clicked on the module.

on-click-middle:
typeof: string
Command to execute when middle-clicked on the module using mousewheel.

on-click-right:
typeof: string
Command to execute when you right clicked on the module.

on-update:
typeof: string
Command to execute when the module is updated.

on-scroll-up:
typeof: string
Command to execute when scrolling up on the module.

on-scroll-down:
typeof: string
Command to execute when scrolling down on the module.

smooth-scrolling-threshold:
typeof: double
Threshold to be used when scrolling.

tooltip:
typeof: bool
default: true
Option to disable tooltip on hover.

{percentage}: Percentage of memory in use.

{swapPercentage}: Percentage of swap in use.

{total}: Amount of total memory available in GiB.

{swapTotal}: Amount of total swap available in GiB.

{used}: Amount of used memory in GiB.

{swapUsed}: Amount of used swap in GiB.

{avail}: Amount of available memory in GiB.

{swapAvail}: Amount of available swap in GiB.

"memory": {
	"interval": 30,
	"format": "{}% ",
	"max-length": 10
}

"memory": {
	"interval": 30,
	"format": "{used:0.1f}G/{total:0.1f}G "
}

#memory
2022-06-08

Search for    or go to Top of page |  Section 5 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.