GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
TICKIT_RECT(7) FreeBSD Miscellaneous Information Manual TICKIT_RECT(7)

TickitRect - utility structure representing a rectangular region

#include <tickit.h>

typedef struct {
  int top;
  int left;
  int lines;
  int cols;
} TickitRect;

A TickitRect structure represents a single non-empty rectangular region of the screen. It stores the position of the top left corner of the region, and its size in lines and columns.

A new TickitRect structure can be initialised using the tickit_rect_init_sized(3) and tickit_rect_init_bounded(3) functions. Its bottom right corner can be obtained using tickit_rect_bottom(3) and tickit_rect_right(3). Interactions between rectangles can be tested using the predicate functions tickit_rect_contains(3) and tickit_rect_intersects(3). New rectangles can be created from existing ones using tickit_rect_intersect(3) to form the intersection, tickit_rect_add(3) to form the union sum, and tickit_rect_subtract(3).

Search for    or go to Top of page |  Section 7 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.