GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
RABBITMQ-DIAGNOSTICS(8) FreeBSD System Manager's Manual RABBITMQ-DIAGNOSTICS(8)

rabbitmq-diagnostics
RabbitMQ diagnostics, monitoring and health checks tools

rabbitmq-diagnostics [-q] [-s] [-l] [-n node] [-t timeout] command [command_options]

rabbitmq-diagnostics is a command line tool that provides commands used for diagnostics, monitoring and health checks of RabbitMQ nodes. See the RabbitMQ documentation guides to learn more about RabbitMQ diagnostics, monitoring and health checks.

rabbitmq-diagnostics allows the operator to inspect node and cluster state. A number of health checks are available to be used interactively and by monitoring tools.

By default if it is not possible to connect to and authenticate with the target node (for example if it is stopped), the operation will fail. To learn more, see the RabbitMQ Monitoring guide

node
Default node is “rabbit@target-hostname”, where target-hostname is the local host. On a host named “myserver.example.com”, the node name will usually be “rabbit@myserver” (unless RABBITMQ_NODENAME has been overridden). The output of “hostname -s” is usually the correct suffix to use after the “@” sign. See rabbitmq-server(8) for details of configuring a RabbitMQ node.
, --quiet
Quiet output mode is selected. Informational messages are reduced when quiet mode is in effect.
, --silent
Silent output mode is selected. Informational messages are reduced and table headers are suppressed when silent mode is in effect.
timeout, --timeout timeout
Operation timeout in seconds. Not all commands support timeouts. Default is infinity.
, --longnames
Must be specified when the cluster is configured to use long (FQDN) node names. To learn more, see the RabbitMQ Clustering guide
cookie
Shared secret to use to authenticate to the target node. Prefer using a local file or the RABBITMQ_ERLANG_COOKIE environment variable instead of specifying this option on the command line. To learn more, see the RabbitMQ CLI Tools guide

Most commands provided by rabbitmq-diagnostics inspect node and cluster state or perform health checks.

Commands that list topology entities (e.g. queues) use tab as column delimiter. These commands and their arguments are delegated to rabbitmqctl(8).

Some commands ( list_queues, list_exchanges, list_bindings and list_consumers) accept an optional vhost parameter.

The list_queues, list_exchanges and list_bindings commands accept an optional virtual host parameter for which to display results. The default value is “/”.

[-l] [command_name]

Prints usage for all available commands.

, --list-commands
List command usages only, without parameter explanation.
command_name
Prints usage for the specified command.

Displays CLI tools version

See wait in rabbitmqctl(8)

See cluster_status in rabbitmqctl(8)

See list_users in rabbitmqctl(8)

[-p vhost]

See list_permissions in rabbitmqctl(8)

[-p vhost]

See list_topic_permissions in rabbitmqctl(8)

username

See list_user_permissions in rabbitmqctl(8)

username

See list_user_topic_permissions in rabbitmqctl(8)

[vhostinfoitem ...]

See list_vhosts in rabbitmqctl(8)

Lists resource alarms, if any, in the cluster.

See RabbitMQ Resource Alarms guide to learn more.

Example:

rabbitmq-diagnostics alarms

Displays the node certificates for every listener on target node that is configured to use TLS.

Example:

rabbitmq-diagnostics certificates

Health check that fails (returns with a non-zero code) if there are alarms in effect on any of the cluster nodes.

See RabbitMQ Resource Alarms guide to learn more.

Example:

rabbitmq-diagnostics check_alarms
[--unit time_unit] [--within seconds]

Checks the expiration date on the certificates for every listener on target node that is configured to use TLS. Supported time units are:

  • days
  • weeks
  • months
  • years

Example:

rabbitmq-diagnostics check_certificate_expiration --unit weeks --within 6

Health check that fails (returns with a non-zero code) if there are alarms in effect on the target node.

See RabbitMQ Resource Alarms guide to learn more.

Example:

rabbitmq-diagnostics check_local_alarms

Health check that fails (returns with a non-zero code) if any listener ports on the target node cannot accept a new TCP connection opened by rabbitmq-diagnostics

The check only validates if a new TCP connection is accepted. It does not perform messaging protocol handshake or authenticate.

See RabbitMQ Networking guide to learn more.

Example:

rabbitmq-diagnostics check_port_connectivity
port

Health check that fails (returns with a non-zero code) if the target node is not listening on the specified port (there is no listener that uses that port).

See RabbitMQ Networking guide to learn more.

Example:

rabbitmq-diagnostics check_port_listener 5672
protocol

Health check that fails (returns with a non-zero code) if the target node does not have a listener for the specified protocol.

See RabbitMQ Networking guide to learn more.

Example:

rabbitmq-diagnostics check_protocol_listener mqtt

Health check that fails (returns with a non-zero code) if the RabbitMQ application is not running on the target node.

If rabbitmqctl(8) was used to stop the application, this check will fail.

Example:

rabbitmq-diagnostics check_running

Health check that checks if all vhosts are running in the target node

Example:

rabbitmq-diagnostics check_virtual_hosts --timeout 60

Lists cipher suites enabled by default. To list all available cipher suites, add the --all argument.

Example:

rabbitmq-diagnostics cipher_suites --format openssl --all

Displays target node's command-line arguments and flags as reported by the runtime.

Example:

rabbitmq-diagnostics command_line_arguments -n rabbit@hostname
[--duration seconds | -d seconds] [--pattern pattern] [--timeout milliseconds]

Streams internal events from a running node. Output is jq-compatible.

Example:

rabbitmq-diagnostics consume_event_stream -n rabbit@hostname --duration 20 --pattern queue_.*

Runs a peer discovery on the target node and prints the discovered nodes, if any.

See RabbitMQ Cluster Formation guide to learn more.

Example:

rabbitmq-diagnostics discover_peers --timeout 60
See environment in rabbitmqctl(8)

Outputs a hashed value of the shared secret used by the target node to authenticate CLI tools and peers. The value can be compared with the hash found in error messages of CLI tools.

See RabbitMQ Clustering guide to learn more.

Example:

rabbitmq-diagnostics erlang_cookie_hash -q

Reports target node's Erlang/OTP version.

Example:

rabbitmq-diagnostics erlang_version -q

Reports if RabbitMQ application is currently booting (not booted/running or stopped) on the target node.

Example:

rabbitmq-diagnostics is_booting

Reports if RabbitMQ application is fully booted and running (that is, not stopped) on the target node.

Example:

rabbitmq-diagnostics is_running
[-p vhost] [bindinginfoitem ...]

See list_bindings in rabbitmqctl(8)

[channelinfoitem ...]

See list_channels in rabbitmqctl(8)

See list_ciphers in rabbitmqctl(8)

[connectioninfoitem ...]

See list_connections in rabbitmqctl(8)

[-p vhost]

See list_consumers in rabbitmqctl(8)

[-p vhost] [exchangeinfoitem ...]

See list_exchanges in rabbitmqctl(8)

See list_hashes in rabbitmqctl(8)

[-p vhost] [--offline | --online | --local] [queueinfoitem ...]

See list_queues in rabbitmqctl(8)

[--local] [--queue-timeout milliseconds] [column ...] [--no-table-headers]

See list_unresponsive_queues in rabbitmqctl(8)

Lists listeners (bound sockets) on this node. Use this to inspect what protocols and ports the node is listening on for client, CLI tool and peer connections.

See RabbitMQ Networking guide to learn more.

Example:

rabbitmq-diagnostics listeners
--number number | number [--timeout milliseconds]

Prints the last N lines of the log on the node

Example:

rabbitmq-diagnostics log_tail -number 100
[--duration seconds | -d seconds] [--timeout milliseconds]

Streams logs from a running node for a period of time

Example:

rabbitmq-diagnostics log_tail_stream --duration 60

Periodically samples stack traces of all Erlang processes ("lightweight threads") on the node. Reports the processes for which stack trace samples are identical.

Identical samples may indicate that the process is not making any progress but is not necessarily an indication of a problem.

Example:

rabbitmq-diagnostics maybe_stuck -q
[--unit memory_unit]

Displays node's memory usage by category. Supported memory units are:

  • bytes
  • megabytes
  • gigabytes
  • terabytes

See RabbitMQ Memory Use guide to learn more.

Example:

rabbitmq-diagnostics memory_breakdown --unit gigabytes
[--interval seconds]

Starts a CLI observer interface on the target node

Example:

rabbitmq-diagnostics observer --interval 10

Most basic health check. Succeeds if target node (runtime) is running and rabbitmq-diagnostics can authenticate with it successfully.

See report in rabbitmqctl(8)

[--sample-interval interval]

Performs sampling of runtime (kernel) threads' activity for interval seconds and reports it.

For this command to work, Erlang/OTP on the target node must be compiled with microstate accounting support and have the runtime_tools package available.

Example:

rabbitmq-diagnostics runtime_thread_stats --sample-interval 15
[--no_table_headers] [column ...] [--timeout milliseconds]

See schema_info in rabbitmqctl(8)

Reports target node's version.

Example:

rabbitmq-diagnostics server_version -q

See status in rabbitmqctl(8)

Lists all TLS versions supported by the runtime on the target node. Note that RabbitMQ can be configured to only accept a subset of those versions, for example, SSLv3 is disabled by default.

See RabbitMQ TLS guide to learn more.

Example:

rabbitmq-diagnostics tls_versions -q

See list_global_parameters in rabbitmqctl(8)

[-p vhost]

See list_parameters in rabbitmqctl(8)

[-p vhost]

See list_operator_policies in rabbitmqctl(8)

[-p vhost]

See list_policies in rabbitmqctl(8)

[--vhost vhost] [--global] [--no-table-headers]

See list_vhost_limits in rabbitmqctl(8)

[--all | -a] [--timeout milliseconds]

Shows log file location(s) on target node

Example:

rabbitmq-diagnostics log_location -a

[column ...] [--timeout milliseconds]

See list_feature_flags in rabbitmqctl(8)

queue [--vhost vhost]

See quorum_status in rabbitmq-queues(8)

See check_if_node_is_mirror_sync_critical in rabbitmq-queues(8)

See check_if_node_is_quorum_critical in rabbitmq-queues(8)

rabbitmqctl(8), rabbitmq-server(8), rabbitmq-queues(8), rabbitmq-upgrade(8), rabbitmq-service(8), rabbitmq-env.conf(5), rabbitmq-echopid(8)

The RabbitMQ Team <info@rabbitmq.com>
June 19, 2021 RabbitMQ Server

Search for    or go to Top of page |  Section 8 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.