GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
RABBITMQ-QUEUES(8) FreeBSD System Manager's Manual RABBITMQ-QUEUES(8)

rabbitmq-queues
RabbitMQ queue management tools

rabbitmq-queues [-q] [-s] [-l] [-n node] [-t timeout] command [command_options]

rabbitmq-queues is a command line tool that provides commands used to manage queues, for example, grow, shrink or rebalance replicas of replicated queue types. See the RabbitMQ quorum queues guide and the general RabbitMQ queues guide to learn more about queue types in RabbitMQ.

node
Default node is “rabbit@target-hostname”, where target-hostname is the local host. On a host named “myserver.example.com”, the node name will usually be “rabbit@myserver” (unless RABBITMQ_NODENAME has been overridden). The output of “hostname -s” is usually the correct suffix to use after the “@” sign. See rabbitmq-server(8) for details of configuring a RabbitMQ node.
, --quiet
Quiet output mode is selected. Informational messages are reduced when quiet mode is in effect.
, --silent
Silent output mode is selected. Informational messages are reduced and table headers are suppressed when silent mode is in effect.
timeout, --timeout timeout
Operation timeout in seconds. Not all commands support timeouts. Default is infinity.
, --longnames
Must be specified when the cluster is configured to use long (FQDN) node names. To learn more, see the RabbitMQ Clustering guide
cookie
Shared secret to use to authenticate to the target node. Prefer using a local file or the RABBITMQ_ERLANG_COOKIE environment variable instead of specifying this option on the command line. To learn more, see the RabbitMQ CLI Tools guide

Displays general help and commands supported by rabbitmq-queues.

node selector --vhost-pattern pattern --queue-pattern pattern --errors-only

Adds a new replica on the given node for all or a half of matching quorum queues.

Supported selector values are:

all
Selects all quorum queues
even
Selects quorum queues with an even number of replicas

Example:

rabbitmq-queues grow “rabbit@newhost” “all” --vhost-pattern “a-vhost” --queue-pattern “.*”
type --vhost-pattern pattern --queue-pattern pattern

Rebalances queue leader replicas across cluster nodes.

Supported type values are:

all
All queue types
quorum
Only quorum queues
classic
Only classic queues

Example:

rabbitmq-queues rebalance “all” --vhost-pattern “a-vhost” --queue-pattern “.*”
node

Shrinks quorum queue clusters by removing any members (replicas) on the given node.

Example:

rabbitmq-queues shrink “rabbit@decomissioned-node”

queue node --vhost virtual-host

Adds a quorum queue member (replica) on the given node.

Example:

rabbitmq-queues add_member --vhost “a-vhost” “a-queue” “rabbit@new-node”
queue node --vhost virtual-host

Removes a quorum queue member (replica) on the given node.

Example:

rabbitmq-queues delete_member --vhost “a-vhost” “a-queue” “rabbit@decomissioned-node”

queue --vhost virtual-host

Displays quorum status of a quorum queue.

Example:

rabbitmq-queues quorum_status --vhost “a-vhost” “a-queue”

Health check that exits with a non-zero code if there are classic mirrored queues without online synchronised mirrors (queues that would potentially lose data if the target node is shut down).

Example:

rabbitmq-queues check_if_node_is_mirror_sync_critical

Health check that exits with a non-zero code if there are queues with minimum online quorum (queues that would lose their quorum if the target node is shut down).

Example:

rabbitmq-queues check_if_node_is_quorum_critical

rabbitmqctl(8), rabbitmq-diagnostics(8), rabbitmq-server(8), rabbitmq-upgrade(8), rabbitmq-service(8), rabbitmq-env.conf(5), rabbitmq-echopid(8)

The RabbitMQ Team <info@rabbitmq.com>
June 19, 2021 RabbitMQ Server

Search for    or go to Top of page |  Section 8 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.