GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
IASL(8) FreeBSD System Manager's Manual IASL(8)

iasl
Intel ACPI compiler/decompiler

iasl [-2cefghl] [-b type] [-d file] [-dc file] [-hc] [-hr] [-i type] [-ln] [-ls] [-oa] [-of] [-oi] [-on] [-ot] [-p prefix] [-s type] [-t type] [-vi] [-vo] [-vr] [-vs] [-x level] [-w level] input-file

The iasl utility is a compiler/decompiler for ACPI Source Language (ASL) and ACPI Machine Language (AML). Major features of iasl include:
  • Full support for the ACPI 3.0b Specification including ASL grammar elements and operators.
  • Extensive compiler syntax and semantic error checking, especially in the area of control methods. This reduces the number of errors that are not discovered until the AML code is actually interpreted (i.e., the compile-time error checking reduces the number of run-time errors).
  • Multiple types of output files, including formatted listing files with intermixed source, several types of AML files, and error messages.

Emit ACPI 2.0 compatible ASL code.
-Sm p | |
Create compiler debug/trace file (*.txt). Types: Parse/Tree/Both.
Parse only, no output generation.
file
Disassemble AML to ASL source code file (*.dsl).
file
Disassemble AML and immediately compile it. (Obtain DSDT from current system if no input file.)
Generate External() statements for unresolved symbols.
Ignore errors, force creation of AML output file(s).
Get ACPI tables and write to files (*.dat).
Additional help and compiler debug options.
Display operators allowed in constant expressions.
Display ACPI reserved method names.
-Sm a |
Create assembler or C include file (*.inc or *.h).
Create mixed listing file (ASL source and AML) (*.lst).
Create namespace file (*.nsp).
Create combined source file (expanded includes) (*.src).
Disable all optimizations (compatibility mode).
Disable constant folding.
Disable integer optimization to Zero/One/Ones.
Disable named reference string optimization.
Display compile times.
prefix
Specify filename prefix for all output files (including .aml).
-Sm a |
Create AML in assembler or C source file (*.asm or *.c).
a|c
Create AML in assembler or C hex table (*.hex).
Less verbose errors and warnings for use with IDEs.
Enable optimization comments.
Disable remarks.
Disable signon.
level
Set debug level for trace output.
level
Set warning level.

acpi(4), acpidump(8)

The iasl utility is provided with Intel ACPI-CA. It first appeared in FreeBSD 5.2.

The iasl utility was written by Intel. This manual page was written by Nate Lawson.
May 20, 2008 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 8 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.