GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
ACCF_DNS(9) FreeBSD Kernel Developer's Manual ACCF_DNS(9)

accf_dns
buffer incoming DNS requests until the whole first request is present

options INET

options ACCEPT_FILTER_DNS

kldload accf_dns

This is a filter to be placed on a socket that will be using accept() to receive incoming connections.

It prevents the application from receiving the connected descriptor via accept() until a whole DNS request is available on the socket. It does this by reading the first two bytes of the request, to determine its size, and waiting until the required amount of data is available to be read.

The ACCEPT_FILTER_DNS kernel option is also a module that can be enabled at runtime via kldload(8) if the INET option has been compiled into the kernel.

If the accf_dns module is available in the kernel, the following code will enable the DNS accept filter on a socket sok.
	struct accept_filter_arg afa;

	bzero(&afa, sizeof(afa));
	strcpy(afa.af_name, "dnsready");
	setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));

setsockopt(2), accept_filter(9), accf_data(9), accf_http(9)

The accept filter mechanism was introduced in FreeBSD 4.0.

This manual page and the filter were written by David Malone.
July 16, 2008 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.